Fiat 124 Spider Forum banner
1 - 14 of 14 Posts

·
Premium Member
Joined
·
38 Posts
Discussion Starter · #1 ·
I have purchased the upgrade kit from www.124spider.uk to install Apple CarPlay in my 2017 Abarth.
Took it all to an auto electrician who did the firmware update.

So the firmware is now 70.00.100A-NA.

But he told me that stage three of the firmware upgrade, the change of branding from Mazda to Abarth simply would not work.

Then he installed the new usb hub.

Most of it works fine, through the iPhone connected by cable and CarPlay running. A few things don’t work. Auto locking especially does not work so I am going to have to teach myself to lock it each time I park it.

I have tried to do the stage 3 brand change myself following the links through Ameridan thatI found on the forum.

I formatted a USB disk to fat 32, copied the necessary files, all looked fine, matched the pictures in the instructions.

I put the drive the top USB port, waited 15 minutes, but nothing happened. It just seems to stick and do nothing at all. Tried several times, ensured phone had been unpaired and iPhone’s Bluetooth was turned off. Audio source was FM per Ameridan’s instructions.

But still nothing happens.

I can actually live with the Mazda branding, as all I was really looking for was a good navigation system and I can use Waze through my phone. Also able to listen to my podcasts or the music from my phone perfectly OK. And the phone thru CarPlay works fine.

But it would be nice to have the Abarth symbol show up.

I wonder too whether would give full functionality on things like automatic locking and Bluetooth if the branding is right.

By the way, I also purchased wireless phone charger kit from 124 Spider, which has also been installed and worked perfectly well.

However as Bluetooth does not seem to work properly and I have to link the iPhone by cable to get CarPlay to work the wireless charger is superfluous.

Anybody got any suggestions?
 

·
Premium Member
2019 Abarth
Joined
·
74 Posts
The seller in UK has a reputation of being very customer service oriented from my observations here to include an owner who spent considerable time talking to him over the phone while installing. The seller would be the first one to contact for advice. Ameridan’s instructions include loading initial software that allows any software screwups to be undone, but hard to know if either your seller included the same thing or the installer used it. I hope you find a solution to your problem.
 

·
Registered
Joined
·
422 Posts
I’m not certain this can be done now that the firmware has been updated. You might want to see if I can be done through a ‘serial hack’, it sound brutal but it’s not and is the method that people use if things ‘screw up’.
 

·
Premium Member
Joined
·
38 Posts
Discussion Starter · #4 ·
I have emailed the seller in the UK, who has been very helpful up till now. No reply yet but I am confident there will be one.

I will post the reply.
 

·
Premium Member
Joined
·
38 Posts
Discussion Starter · #5 ·
Can you explain, or give me a link to a serial hack please.
 

·
Premium Member
Joined
·
38 Posts
Discussion Starter · #7 ·

·
Registered
2017 Spider Abarth AT
Joined
·
679 Posts
Given that you can’t install tweaks (rebranding or otherwise) through the USB port, I’m guessing that either the id7 patch was not included in your upgrade kit or else it was and the shop who installed your upgrade did not install it. I would ask the seller if the id7 patch was included with the kit. As Chris said, the id7 patch needs to be installed before upgrading the system software. The only way to restore USB tweak access if id7 was not installed before the system software was upgraded is to do the serial hack. The serial access hack instructions can be found here. I’m not familiar with the wireless charging kit, but the system software update should not have affected the Bluetooth or door locking issues you’re having. Don’t know why you have those problems. More questions for the fellow who sold you the kit.
 

·
Registered
2017 124 Classica
Joined
·
379 Posts
The only concern I personally have here (sorry I can't help with the problem) is that you reported the Auto-Locking not working.

Is that something anyone else has reported with that upgrade? Because not having auto-locking is gonna be a total deal killer for me upgrading if that's a thing.
 

·
Premium Member
Joined
·
38 Posts
Discussion Starter · #10 ·
I am going to follow up on that with spider124.uk.

I understand your point, but it is not a dealbreaker for me.

When you go into the settings you will find that you are not able to tick the auto locking. Like the Mazda logo I can live with that in order to have everything else that Apple CarPlay gives.
 
  • Like
Reactions: Walshy6677

·
Registered
Joined
·
422 Posts
The only concern I personally have here (sorry I can't help with the problem) is that you reported the Auto-Locking not working.

Is that something anyone else has reported with that upgrade? Because not having auto-locking is gonna be a total deal killer for me upgrading if that's a thing.
It’s odd, my auto lock doesn’t work either (i did this upgrade some time ago). I’ll check in the settings to see if there is a setting issue. On balance the upgrade wins over auto lock anyway, at least for me, I think CarPlay is a brilliant system.
 

·
Registered
2017 Spider Abarth AT
Joined
·
679 Posts
Just a thought. Have you rebooted the system (holding down the Nav and Mute buttons) until the system reboots. Might not make any difference but worth the try if you haven’t already done it.

FWIW I’ve not had any problems with auto/locking or Bluetooth post upgrade.
 

·
Premium Member
Joined
·
38 Posts
Discussion Starter · #13 ·
Here is the response from 124spider.uk.

I have some options to try and will report in due course. The bit that frightens me is the serial connection. I will seek help on that.


“Hi John,

The usual reason for the final step (Mazda to Fiat conversion) not working is because the first step (ID7 recovery installation) was not completed successfully or was skipped.

As stated in the instructions, this first step is imperative to enable the Mazda to Fiat conversion at the end of the installation process. If it was not completed, the only solution is to connect to the CMU remotely using a serial connection and re-run the ID7 installation, as described here: Serial Connection

124 Spider UK
Web: https://124spider.uk
Email: [email protected]
 

·
Registered
Joined
·
422 Posts
Here is the response from 124spider.uk.

I have some options to try and will report in due course. The bit that frightens me is the serial connection. I will seek help on that.


“Hi John,

The usual reason for the final step (Mazda to Fiat conversion) not working is because the first step (ID7 recovery installation) was not completed successfully or was skipped.

As stated in the instructions, this first step is imperative to enable the Mazda to Fiat conversion at the end of the installation process. If it was not completed, the only solution is to connect to the CMU remotely using a serial connection and re-run the ID7 installation, as described here: Serial Connection

124 Spider UK
Web: https://124spider.uk
Email: [email protected]
That is exactly what happened to me. As it turned out, when I initially copied the files over to the usb memory stick some of the files didn’t copy for some reason, it is important to check they all copied over. To this day I am not sure why, but my issue went beyond the logo issue, I couldn’t complete the installation at all and was left in a place with nothing at all. I looked into the serial hack, you need some equipment, it’s quite cheap, the links are below. I was a bit freaked out as well and so once I had everything stripped out (easy), I did the rest with help from a guy who had done it before (over a video link) and it worked, but it was a bit stressful at the time. The piggy back wires gave me some extra length to utilise (see picture) from my PC to the car. Good luck.
Motor vehicle Vehicle Automotive design Automotive tire Automotive lighting


 
1 - 14 of 14 Posts
Top