Fiat 124 Spider Forum banner
341 - 355 of 355 Posts

·
Registered
Joined
·
3 Posts
Just did the whole install thanks to all who wrote this up
Ameridan and 68wooley
You guys rock !

Infotainment is super snappy when using CarPlay it almost feels like a brand new system ! If you have not done this I HIGHLY recommend it !
Question: I would like to do this to my newly purchased 2017 Abarth but the download links on the original post don’t have files in them anymore. How did you get yours?
 

·
Registered
Joined
·
80 Posts
Question: I would like to do this to my newly purchased 2017 Abarth but the download links on the original post don’t have files in them anymore. How did you get yours?
I did it before the download links disappeared
 

·
Registered
Joined
·
142 Posts
I have these 3 zip files in my Downloads folder from when I did my upgrade. PM me if any of them are of use to you. I honestly don't recall if this was everything or not.

87621
 

·
Registered
Joined
·
47 Posts
If you do this mod, DON'T INSTALL TOUCH SCREEN WHILE MOVING TWEAK.

for some reason the touch screen works on android auto screen but there is no sound when using android auto (no nav no music no nothing)

when i reinstalled the firmware 70.000.100 everything was good. I was able to install the tweaks EXCEPT enable touch screen.
 

·
Premium Member
Joined
·
472 Posts
Can I hire anyone in this thread to do the serial method for me? Anyone in Arizona or visiting Arizona? My car is a 2020 running version 59.
 

·
Registered
Joined
·
1 Posts
Is there anyone who can help me out with

cmu150_NA_70.00.100A_failsafe.up
cmu150 NA_70.00.100A_reinstall.up
files, I’m trying to upgrade my daughters car and did not realize the servers were taken down recently
 

·
Registered
'17 Abarth AT track tool
Joined
·
24 Posts
Anyone experienced an issue where a fully operational CarPlay simply stopped working? It first started when I was pushing my knee into the tunnel in sharp turns, the phone would disconnect, and I had to reinsert the cable to get it back. But at a certain point it stopped working completely.

Funny thing is the phone still charges using the USB port, just no sights of CP on the head-unit.

I'll appreciate your advice
 

·
Registered
Joined
·
3 Posts
I'm also searching for these files. Does anyone have them?

cmu150_NA_70.00.100A_failsafe.up
cmu150 NA_70.00.100A_reinstall.up
 
341 - 355 of 355 Posts
Top