Fiat 124 Spider Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
i have a 2017 124 Spider Lusso. Noticed my center brake light was out and the license plate lights were not working. I checked the fuses and replace the ones that were for that specific issue even though they seemed OK and still can’t get anything resolved. Does anyone know what might cause this or have the same issue?
 

·
Registered
Joined
·
105 Posts
Look for water in the license plate light covers. They are not as water tight as they should be. I have seen water get in there when washing the car at the car wash or with a pressure washer. That could cause a short.

The next option is to check the wiring harness in the trunk.. Its in the left corner just under the trunk hinge, there is a harness there that might have been damaged by items in the trunk.

If it neither of those then you need to check voltage with a multi meter or take it to the dealer.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
Look for water in the license plate light covers. They are not as water tight as they should be. I have seen water get in there when washing the car at the car wash or with a pressure washer. That could cause a short.

The next option is to check the wiring harness in the trunk.. Its in the left corner just under the trunk hinge, there is a harness there that might have been damaged by items in the trunk.

If it neither of those then you need to check voltage with a multi meter or take it to the dealer.
Thank you! I will try those options real quick.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
Ended up
Look for water in the license plate light covers. They are not as water tight as they should be. I have seen water get in there when washing the car at the car wash or with a pressure washer. That could cause a short.

The next option is to check the wiring harness in the trunk.. Its in the left corner just under the trunk hinge, there is a harness there that might have been damaged by items in the trunk.

If it neither of those then you need to check voltage with a multi meter or take it to the dealer.
taking to the dealer
Look for water in the license plate light covers. They are not as water tight as they should be. I have seen water get in there when washing the car at the car wash or with a pressure washer. That could cause a short.

The next option is to check the wiring harness in the trunk.. Its in the left corner just under the trunk hinge, there is a harness there that might have been damaged by items in the trunk.

If it neither of those then you need to check voltage with a multi meter or take it to the dealer.
ended up go to the dealer. Has a bad wiring harness. Says part is 153 bucks and wants 200 in labor to install. Going to to see if i can find parts myself.
 

·
Registered
Joined
·
105 Posts
I'm sorry Ididn't have a fix for you but thanks for following up as it might help the next guy. Looking for the part outside the dealer is a good idea. Hopefully it is something you can replace yourself as these cars are actually pretty easy to work on. Good luck, bud!
 

·
Registered
Joined
·
431 Posts
Ended up

taking to the dealer

ended up go to the dealer. Has a bad wiring harness. Says part is 153 bucks and wants 200 in labor to install. Going to to see if i can find parts myself.
A wiring harness shouldn't go bad as a whole, there might be a broken wire that can be repaired.
 
1 - 7 of 7 Posts
Top