Fiat 124 Spider Forum banner

1 - 20 of 40 Posts

Registered
Joined
638 Posts
Discussion Starter · #1 ·
Is it just me but I have a 5 km/h difference between the speed I set on cruise control vs the real speed shown on the speedometer (both real and the one in the Ameridan's tweaks)? Maybe it's related with gear ratio difference of manual vs auto tranny or 124 vs MX-5? I only use CC on highway when over 100 km/h in the 6th gear (MT).

For those who never noticed it, the CC set speed is shown in upper left pod along with the car / trip mileage.

I suppose US owner have maybe a difference of 2-3 mph?

This is not a big issue for me but now that I have my first dealer service planned in a couple of weeks before winterizing I may report it to them. If I see all others 124 owners have that isses I may simply live with it.
 

Registered
Joined
556 Posts
never noticed... of course never looked...
I'll look next time on highway
 

Registered
Joined
2,211 Posts
Nope - seems to match up to the speedometer pretty well for me. We've lots of heavily enforced constructions zones around here at the moment so I use it regularly to keep to the posted limit in those.

How accurate the speedometer really is is a different question.
 

Registered
Joined
3,951 Posts
The speedometer matches my GPS, so my guess is it's pretty accurate. Cruise control seems to hold speed well, too.
 
  • Like
Reactions: wedgewa

Registered
Joined
638 Posts
Discussion Starter · #6 ·
The speedometer matches my GPS, so my guess is it's pretty accurate. Cruise control seems to hold speed well, too.
I didn't check the accuracy of my speedometer vs my phone GPS yet but I guess I should before I get a surprise (speed ticket)...loll

My CC is pretty stable too but that's not what bugs me. It's the speed shown in the upper left pods (CC set speed) vs the actual speed shown on the speedometer or the UI tweaks speedometer. For example when I set the CC on at 115km/h the speed shown on the upper left pod is around 120km/h.
 

Registered
Joined
3,047 Posts
Wolf, so far very accurate, maybe the CC takes in account the city you're in. I know in LABAUME Land, the speedometer is a couple km less than the CC. This is to avoid speeding tickets.:D
If I come to Quebec city, I will check that out.>:)
 
  • Like
Reactions: wolf18t

Registered
Joined
3 Posts
I have an Abarth with Auto and need to set Cruise at about 116 kph to get 110kph. It might be a Canadian thing but it seems wrong. I judge by GPS speed limit going Red or staying White. Be curious if dealer has any info, probably won't take mine in until next spring. Our KM speedometers are too difficult to read as width can be 2-3 km but it looks right just CC messed up.
 

Registered
Joined
350 Posts
Mine matches pretty much what I set it to in my Abarth AT, it may go a MPH or 2 when going down hill. I find the speed indicated on the speedometer to be fairly accurate as well.
 

Registered
Joined
28 Posts
I used the CC on my Classica a week or two ago between Los Angeles and Palm Springs, and didn't notice any difference at all between the set and actual speeds. I also believe the speedometer is pretty dead on accurate in mine.
 

Registered
Joined
638 Posts
Discussion Starter · #12 ·
Well it seems like a Canadian or metric issue. Any European / Aussie owners could check this?
 

Registered
Joined
114 Posts
Its not just Canada - I set the CC to 73mph to get 70mph according to GPS. This isn't unique to this car, my previous 2 cars and my wifes (various VAG) have all had similar but inconsistent differences.
 

Registered
Joined
660 Posts
Mine wanders from about 2 MPH under the set speed to 3 MPH over, compared to GPS speed. It is not as accurate at holding a set speed as my 500 and 500l.
 

Registered
Joined
10 Posts
Hi. I have the same issue. I have to set my cc to 116 k/h to keep the speed of my Abarth (AT) at 110 k/h. I whish there was a fix for this.
 

Registered
Joined
3 Posts
I have taken my car in several times for this issue. CC is anywhere from 6 to 10 kph off according to the GPS. Dealer replaced the CC cluster, which did not fix the problem but made it more consistent. CC now reads 6 kph too high at all speeds. I now consider 'the fault' to be a unique Canadian feature. BTW, if the CC cluster is replaced, it resets the mileage to zero, which on a leased car is a whole different bag of problems.
 

Registered
Joined
1,964 Posts
Well, you all got me looking at this as well but mine is pretty much on the money. The cruise control setting, speedometer, and the analog and digital speedometers from Ameridan tweaks all say the same thing
 
  • Like
Reactions: ameridan

Registered
Joined
3,047 Posts
The other day I put the Cruise control on, and the digital speedometer actually displayed the speed I put the Cruise control, the digital indicator would not budge unless I incremented or decreased the cruise control settings.

I stopped paying attention, it would be good to have digital speedometer display that works especially we have the GPS, my old Garmin tells me the speed I am travelling.

I read that there is a large display of the speedometer. can someone confirm me that. Looks like I am getting old, in fact the Abarth should make me getting younger. LOL
 

Registered
Joined
1,964 Posts
I don't know if this is what you mean or not, but in Ameridan't infotainment tweaks there is a speedometer app, with both analog and a digital readout in the middle. The digital one is certainly easier to see than the car's analog display
 
1 - 20 of 40 Posts
Top