Fiat 124 Spider Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter · #1 · (Edited)
I recently threw a EC phase 1 tune on this and had a couple issues. Today I started it and warmed it up fine, but when I turned onto a hill near my place the car bogged out untill it stalled. Power steering is cut, brakes feel harder, and it won't start. I saw the lightning bolt sign on the dash as well as check engine light. I also see the oil light as well.

Trying to start it sounds pretty bad, I can attach a clip if needed later.

Editing to provide more information:

When I tuned it initially, the tunes failed to upload. It almost exactly did what you can read on a thread from Evolved here. I drove it around a bit, and then the EC PH1 tune failed, but the EC PH1 + Burbles succeeded. I DID NOT immediately do the throttle relearn procedure, forgot to do it. The day after, I did this procedure, but I didn't flash to stock and retune it. Not sure if I needed to do that. In the last couple days I was able to drive it and enjoy it, but it did feel a little underpowered in 1st gear trying to get up that hill another time.

I just tried using the tuner to read any codes, but I don't see any right now. I cleared the P0106 that happened when I relearned the throttle since it was driving fine after I tried that, but now no code
 

·
Premium Member
2018 124 Spider Abarth Custom
Joined
·
2,417 Posts
Did you do the throttle position relearn after the flash?

Push the ON button twice without clutch or brake depending on trans to turn the car on but not start.

Press the accelerator pedal to the floor 5 times within 10 seconds. You don't have to slam it fast but do 5 full presses to the floor.

Turn the car OFF and wait 10 seconds.

Try to start the car.
 

·
Registered
Joined
·
25 Posts
Discussion Starter · #3 ·
Thanks for the reply, I'll admit I forgot to do this immediately after flashing since it wasnt in the instructions at the end, but on their website. I did do this the day after but not after flashing back to stock and back to the tune, so I did this while already tuned not immediately after tuning
 

·
Vendor
Joined
·
3,658 Posts
Thanks for the reply, I'll admit I forgot to do this immediately after flashing since it wasnt in the instructions at the end, but on their website. I did do this the day after but not after flashing back to stock and back to the tune, so I did this while already tuned not immediately after tuning
It's easy to forget this step. Still it might be a good idea to email us so we can double check everything for you.

Greg
 

·
Registered
Joined
·
25 Posts
Discussion Starter · #5 ·
It's easy to forget this step. Still it might be a good idea to email us so we can double check everything for you.

Greg
Thanks Greg, I did email and last I saw Toby said he'd look into any compression issue with the files. Today I'm going to try starting the car and check for any codes. As for the P0106 I'll see if I can do any visual inspection of the hoses. Not sure where to go next if I see P0106 again
 
1 - 5 of 5 Posts
Top