Fiat 124 Spider Forum banner

1 - 20 of 188 Posts

·
Registered
Joined
·
968 Posts
Discussion Starter #1
This thread is to discuss setting up and use of the Forge Wastegate Actuator.

Forge Recirculating valve (Top) Forge Wastegate Actuator (Middle) Forge Intake Pressure Compensation Valve (Bottom)


This unit has come up recently in other topics so it pushed me to look into it further.

@depotdan and I have had it for a while now but haven't really messed with it aside form getting it anodized until yesterday.
We found out that the 048 spring kit that Forge recommends and EC sell on their site is the wrong kit for this actuator.
The 048 (Big body) springs are much larger than the spring in the unit and a quick search on the Forge site brought me to the other kit that is available 049 (Standard body) which is what I think will work in our actuator. But its not that simple the actuator is the piston type and both those kits are for the diaphragm type. They do list a piston type kit but with no corresponding part# which really makes it confusing. I've sent an email to forge about this issue and will report back when i receive an answer.

048 Spring set with actuator arm and stock yellow spring


Stock yellow spring (Left) 048 yellow spring (Right)
 

Attachments

·
Premium Member
Joined
·
2,300 Posts
Mahalo @Phillip33

Soon I'll be ordering this (the recirculating valve)...I may ask for a anodizing favor...again!

btw...it would look sooooooooomuch better in RED!

aloha mike
 

·
Premium Member
2018 124 Spider Abarth Custom
Joined
·
1,323 Posts
I guess I will be sending the 048 kit back as soon as it gets here.
 

·
Premium Member
2018 124 Spider Abarth Custom
Joined
·
1,323 Posts
Just got finished with an email chain to Forge in Florida. The spring kit needed is FMPAC049
 

·
Premium Member
2018 124 Spider Abarth Custom
Joined
·
1,323 Posts
Just got finished with an email chain to Forge in Florida. The spring kit needed is FMPAC049
That's what i was thinking but was waiting for confirmation.
I never got a reply back.
I had put in the cancel request for the 048 and they emailed this morning to ask why. Sent a picture of the WGA and they confirmed the 049 and swapped into my order. I should have them the end of the week along with the IPCV
 

·
Registered
Joined
·
3,348 Posts

·
Registered
Joined
·
968 Posts
Discussion Starter #9
The confusion on the springs probably is because 048 is what is listed on the Forge product page:

https://www.forgemotorsport.com/Turbo_Actuator_for_the_Fiat_14_Multiair--product--74.html

Hopefully you guys are pointing out the issue to Eurocompulsion so they can correct their website.

@[email protected]
Now that we have a confirmed answer we can get it corrected.
I would still wait till the 049 springs have been tested because the Forge site has 3 different listings 048 large diaphragm, 049 standard diaphragm, and Piston type with no part number.
 

·
Premium Member
2018 124 Spider Abarth Custom
Joined
·
1,323 Posts
Springs and IPCV should arrive today. Will get pictures up of them with the one currently in my WGA for visual comparison.
 

·
Premium Member
2018 124 Spider Abarth Custom
Joined
·
1,323 Posts
Springs are in along with the IPCV. Letting the car cool down to pull the WGA and look at the size comparison. Don't think I need them now but at least we will get the issue on part number resolved for everyone.
 

·
Registered
Joined
·
2,236 Posts
This is also on my short list now. After conferring with my unpaid technical advisor (@Phillip33) is it possible that my boost issues are the result of a faulty WGA. But another reason I want to get one is because we get to say crack pressure a lot with this product and somehow that just makes me giggle every time I say it.
 

·
Registered
Joined
·
2,236 Posts
So this is my current issue. I swapped out plugs with no affect. Today I switched back to stock diverter valve with GFB. Problem persists and with GFB peak boost is only 22 from normal 25. Car is strong except for this. I'm hoping it is the WGA. I'm going to flash back to stock tune tomorrow but that tune is so bad that even if it doesn't do this it still has other issues that make for a bad driving experience.

 

·
Registered
Joined
·
3,348 Posts
So this is my current issue. I swapped out plugs with no affect. Today I switched back to stock diverter valve with GFB. Problem persists and with GFB peak boost is only 22 from normal 25. Car is strong except for this. I'm hoping it is the WGA. I'm going to flash back to stock tune tomorrow but that tune is so bad that even if it doesn't do this it still has other issues that make for a bad driving experience.

https://youtu.be/I3Cwt0GdvZI
That’s boost dump. Surprise, Tork has the problem, too. EC solved that issue, by the way.
 

·
Registered
Joined
·
2,236 Posts
That’s boost dump. Surprise, Tork has the problem, too. EC solved that issue, by the way.
Well, the difference here is I'm the only Tork customer with the problem. I'm hoping it is a mechanical issue. John is aware and we have a step-by-step plan to problem solve. The first steps involved the plugs and going back to the stock diverter valve. Next step is change the WGA out. If it turns out to be a tune issue then I have no doubt John will be able to solve it quickly.
 

·
Registered
Joined
·
97 Posts
In regards to the springs, yellow is what we use with a "crack pressure" (when the waste-gate arm just begins to move) of 9-11psi.

Setting the waste-gate to begin to open at that pressure variance is optimal.


Stock Wastegate- 6psi (Stock)

Forge Wastegate- 9-11psi (Yellow Spring)


In regards to the boost fluctuations, it has shown up in some software variances.

These cars require some pretty advanced tuning and it takes some time to align all of the required tables to produce what appears to be a simple peak boost request.

Toby is very precise and calculated in the methodology he uses to determine what needs to be adjusted.

Waste-gate Adjustment Tutorial: (Narrated by Greg)

 

·
Registered
Joined
·
2,236 Posts
In regards to the boost fluctuations, it has shown up in some software variances.
That's interesting. I did not have this issue prior to the U76 recall. Post recall I seem to have all sorts of issues. I've been impressed with Toby's dedication to solving the issues.
 

·
Vendor
Joined
·
3,099 Posts
I really need to make a new wastegate adjusting video. It's a lot easier with a bicycle pump rather than an air compressor.


Greg
 

·
Premium Member
2018 124 Spider Abarth Custom
Joined
·
1,323 Posts
I really need to make a new wastegate adjusting video. It's a lot easier with a bicycle pump rather than an air compressor.


Greg
I bought a radiator/cooling system tester that has a nice hand squeeze pump and hose to clamp onto the WGA. Dial indicator is very low range and large graduations between each PSI.
 
1 - 20 of 188 Posts
Top