Fiat 124 Spider Forum banner

1 - 20 of 21 Posts

·
Registered
Joined
·
830 Posts
Discussion Starter #1
Okay, this is turning into a pet peeve: I haven’t been able to play Pandora in the Fiat in like two months.

When I turn Pandora on my Samsung Galaxy, that black Pandora screen takes over the interface with my phone. For two months now, Pandora plays for like 30 seconds and then it stops and I get a “Connection Lost” message on the car display. That’s it.

I’ve Googled this issue: there are posts on Mazda forums dating back to 2016 when the current MX-5 first launched, but haven’t found a resolution. I called Pandora, and they suggested I clear my history data

I’ve tried clearing my history data on the phone, but it keeps doing it.

I know there’s nothing wrong with the phone because Pandora works well in my Tacoma and now in my new Jeep Wrangler. The only difference is that stupid Mazda interface that takes over the phone when Pandora is activated.

I want to remove that interface but haven’t found a way to do it.

Thoughts?
 

·
Registered
Joined
·
241 Posts
Open the Pandora app on your phone, go to settings, uncheck the "start app from car" box, recheck it...then you should be able to get it to start up on the car's screen.

I have to do this every so often. It's annoying. But it works.
 

·
Registered
Joined
·
830 Posts
Discussion Starter #3
I’m going to try that right now!

Thanks!
 

·
Registered
Joined
·
830 Posts
Discussion Starter #4
Gawd it took forever to find "Settings" on Pandora! But was able to deactivate "Launch from Car".

Hope I can find it again next time I have to do the same.
 

·
Registered
Joined
·
241 Posts
Yeah, the new Pandora app is harder to find it. You used to be able to use the back button to go to the main screen and hit the little gear symbol, now it's kind of hidden. Did it work?
 

·
Registered
Joined
·
830 Posts
Discussion Starter #6
Nope. The stupid car continues to take over the phone and disconnects after 30 seconds or so.

Most annoying!
 

·
Registered
Joined
·
2,076 Posts
Have you tried a hard reset of the ICE? Hold down nav, back and mute for 10 seconds or so until the screen goes blank.
 

·
Registered
Joined
·
830 Posts
Discussion Starter #8
The hard reset didn't do anything.

I ended deleting all the data stored on the app; appears to have worked. But I have been down this road before. In a week or two it will start doing it again.

There's something in the Mazda interface that doesn't like about Pandora. But neither Mazda nor Pandora seem to care enough to want to fix it.
 

·
Registered
Joined
·
830 Posts
Discussion Starter #9
My Sirius free 6-month subscription expired, Pandora doesn't work and I have a shorty antenna that doesn't receive much, so I really have nothing to listen to in the Spider...besides the exhaust ?
 

·
Registered
Joined
·
2,076 Posts
What year is your car Aldo? The Pandora app in Carplay appears to be much more stable than the Fiat / Mazda one and I’d assume the same is true for Android Auto. If you have a 2017 or early 2018, the install is relatively easy.
 

·
Registered
Joined
·
830 Posts
Discussion Starter #11
I have a 2018 Spider.

However, my new Jeep came with Android Auto and am not digging it. Fortunately it was easy to remove. This Fiat, on the other hand...nothing electronic seems easy.
 

·
Registered
Joined
·
241 Posts
You can connect the phone via bluetooth audio (phone audio) without having the Pandora app open on the car, and stream it from the Pandora app on your phone, as well. This is how my wife uses Pandora in her Mazda3. And I use the Pandora app in the same Mazda3 without issue. But when she connects that way, she cannot skip, like, choose stations, etc from the car's display...she has to do it from the phone, which does not go to the black screen as it does when tethered to the car's app.
 

·
Registered
Joined
·
830 Posts
Discussion Starter #14
Aldo, have you installed any app tweaks, like Speedometer or AA? Sounds like something is stealing focus away from Pandora.
No, I haven’t touched anything on the car.

The only mod has been the RoadsterSport exhaust, that’s it. Otherwise it’s totally stock.
 

·
Registered
Joined
·
830 Posts
Discussion Starter #15 (Edited)
You can connect the phone via bluetooth audio (phone audio) without having the Pandora app open on the car, and stream it from the Pandora app on your phone, as well. This is how my wife uses Pandora in her Mazda3. And I use the Pandora app in the same Mazda3 without issue. But when she connects that way, she cannot skip, like, choose stations, etc from the car's display...she has to do it from the phone, which does not go to the black screen as it does when tethered to the car's app.
I think that’s how I am doing it.

After I start the car I turn on the Pandora app on my phone. Once Bluetooth connects and the car senses that Pandora is open on my phone, the Mazda interface takes over, both on the phone and the car. At that point I’m screwed: I cannot navigate Pandora with my phone any more; only with the car. And after 30 seconds, it kills Pandora and shows some stupid message on the dashboard display “Lost Connection. Make sure device has connection.”

And tonight after i did the hard reset and didn’t work, I cleared the data history from the Pandora app, which is the only procedure Pandora customer reps seem to know, and the car started giving out the message I used to get before: “Last station has been deleted...blah blah blah”

Piece of junk.
 

·
Registered
Joined
·
830 Posts
Discussion Starter #16
I was able to get back into my phone’s Pandora settings: the “Launch from Car” box was checked again, after I had disabled it.

I’ll check in the morning if the box remains unchecked and if the car stops taking over my phone when Pandora is running.

Hopefully that solves it.
 

·
Registered
Joined
·
830 Posts
Discussion Starter #17
So I made sure that the box “Launch from Car” was unchecked on Pandora settings.

Upon starting the car and connecting to Bluetooth, the Mazda interface still took over the Pandora app on my phone. However, this time it didn’t kill the streaming music! Yay!

I let it play for 3 minutes...seems to be fine now.

We will see how long until it checks that box by itself and starts acting up again. But at least there seems to be a workaround!

Thanks @zxtwou2 !
 
  • Like
Reactions: zxtwou2

·
Registered
Joined
·
288 Posts
I have a similar problem with Pandora. Used to launch just fine from the car screen but starting giving me problems by not connecting when Pandora was selected. I originally thought it may be due to losing wifi before switching to data. I'd get a message saying something like the Pandora app wasn't available. For now just using bluetooth gets me music without all the Pandora features. Maybe in the spring I'll look in to it further.
 

·
Registered
Joined
·
1,243 Posts
How about skipping Pandora, and bluetooth music connections in general and using a USB thumb drive full of music? Yes, I realize this requires moving music files onto a memory device, and Pandora streams music files that you don't have to own, but it's an alternative. I've got some 3700 songs set up in a permanent shuffled manner, on 2 chips in 2 cars, and it takes the better part of a year of regular driving to hear the same song twice. This took work, but I'm in control. My process, including using 64gig USB drives, are found in a couple places on this board. Works great.

[edit] Would Pandora's operation to the radio work when the phone is attached via a USB cable?

Steve.
 
  • Like
Reactions: Arthur

·
Registered
Joined
·
241 Posts
I have over 30,000 songs on my computer, and I still use Pandora instead of an MP3 player or USB drive because I love hearing something new that I wouldn't have without Pandora playing it for me.
 
1 - 20 of 21 Posts
Top