Fiat 124 Spider Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
First Post...ever and hoping someone can help.
My girlfriend wants a reversing camera on her Abarth 124 Spider (registered August 2018). I researched extensively and bought the genuine Mazda camera and loom from Amayama, Japan, under the impression from lots of discussions that it was a simple plug and play option.
All fitted very easily yesterday but it doesn't work. On selecting reverse it should bring up the rear view on the display but nothing.
Been back through all connections and all OK and the rest of the infotainment system (I dislike that word!) still works fine.
My question is, since the reversing camera is an option on Abarth Spiders, as opposed to Lussos, Classicas etc. where I gather it is standard fitment, is it possible that the firmware to run the camera isn't installed? If not, can I add it?
I have never needed to ask for help on a forum before as usually Internet research can answer any problem but I have Googled this to death so any help would be greatly appreciated.
Thanks, Geoff.
 

·
Registered
Joined
·
11 Posts
I don’t if you got it working but the video in link is pretty enlightening.
You’ve got to disconnect the battery before the car recognizes the camera.

 

·
Registered
Joined
·
2,660 Posts
I think in Canada as of May 1st 2018 the reverse camera is standard equipment on cars.

Before that, Reverse camera came with the Abarth as standard equipment, Classica was an option
and I think Lusso was standard.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
Thank you.
I did get it working about 4 months ago after finding just that information on a Mazda forum.
Disconnected and reconnected the battery and ta daaa it was working.
My now wife loves it and I must say it makes reversing much easier, you can get the rear bumper within inches of any obstacle.
 
1 - 4 of 4 Posts
Top