Fiat 124 Spider Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
1,916 Posts
Discussion Starter #1
Has anyone else noticed a smell of gas / petrol coming from the air / ac system when starting the car after its been sitting for a while?

It's not a big deal as it clears pretty quickly, but I'm just wondering if anyone else has noticed it?
 

·
Registered
Joined
·
241 Posts
I haven't noticed that when using mine, although the exhaust smells very rich (which is normal) on cold start up, so maybe if your hitting the aircon on at the same time and reversing out from where your parked the fumes could be getting sucked in by the fan. Especially if it's in auto and a hot day the a/c fans going to kick in at full belt
 

·
Registered
Joined
·
3 Posts
In the past week, mine has a fuel smell (not exhaust) when stopped at a light w top up. The engine is fully warmed up and the odor goes away when driving. The smell is there whether the a/c is on, the heater is on or neither. I have had the car since May and no issues until about a week ago. I thought maybe I had tracked it into the car from a refueling stop by getting fuel on my shoes, but this is not the cause.
I did install Good-Wins's rear exhaust section only about 2-3 months ago - have checked the connection and seems okay. Again, it'a a fuel smell and not exhaust.
Will head to dealer this week & get them to look at it.
 

·
Registered
Joined
·
1,916 Posts
Discussion Starter #4
Occurs to me I haven’t noticed it for a while - possibly coinciding with me installing the EC catch can.

I get a fair amount of water in the can (condensation) which smells strongly of gas - I wonder if that previously was making it all the way to the intake and then somehow getting in to the ventilation system briefly at startup.
 

·
Registered
Joined
·
114 Posts
Happened to me once when I overfilled the car. I never fill to the top now and it has never occurred again.
 

·
Registered
Joined
·
132 Posts
@68wooley I noticed the same thing this time around. I installed my catch can end of last fall and car went into hybernation, it's been out for a few months now but when I run the AC (not often due to top down). I do get that smell too. I can't see anythign that might be causing this, open to any tips you folks have to check.

Here's my setup of the catch can (I shortened the lines quite a bit since this photo) https://www.124spider.org/threads/catch-can-how-much-oil-after-5k-miles.31044/post-456514
 

·
Registered
Joined
·
1,916 Posts
Discussion Starter #7
Sorry - nothing really to suggest. I only get it occasionally and briefly - it's not been enough of an issue for me to pluck up the energy to deal with a FIAT dealer over.
 
1 - 7 of 7 Posts
Top